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TUTORIAL I – WORKING WITH FLEDERMAUS DATA OBJECTS 

Working with Fledermaus Data Objects 
Introduction 

he visualization system is designed from the ground up to provide flexible object-oriented 
visualization. Each loaded data set in the system is considered an object. The system 
supports many different types of objects, which can be categorized into two types, either 
visual data objects or container objects, also called container nodes. Visual data objects are 

designed to display some type of data within the system.  

For example, surfaces are often visualized using the BasicDTM or SonarDTM visual object types. 
This object type displays a shaded, uniformly gridded surface. It supports several different ways of 
representing the surface, such as a wire frame or a shaded surface. The BasicDTM object 
encapsulates all the necessary data to represent the surface along with the know-how to visualize that 
particular data. 
 
When multiple objects are loaded the scene does not merely consist of a large collection of polygons 
but rather a collection of self-contained objects, which work together to represent a scene. This 
allows the easy implementation of features that work at the object level such as geo-referencing and 
object interaction. Visual objects can represent almost anything from a simple plane or grid, to 
complex objects linked to real-time data acquisition systems, or objects whose data evolves over 
time. 
 
Container objects provide data management abilities and allow the system to display multiple objects 
simultaneously. The primary duty of a container node is to manage a list of children objects. Any 
child object can itself be another container object with the ability to manage a list of its children. The 
result is that the system is capable of maintaining a hierarchical tree of objects. This structure 
provides a convenient mechanism for grouping related data. Given that the primary duty of container 
objects is to manage children objects, they often do not themselves contain visual information; 
however, this is not always the case. For example, The CableParent container node is designed to 
manage a group of digital terrain objects. It also adds the ability to store and visualize the route of a 
cable or pipeline that is to be overlaid on the surface. 

OVERVIEW 

I 

T 
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P U R P O S E  
 
Throughout this tutorial you will: 
 

1. Become familiar with the Fledermaus user interface  
2. Load prepared SD files into Fledermaus  
3. Use the widget based interface to navigate around the 3D scene Data 
4. Understand the file selection dialog box 

 
 

Data Input:  MODULE2/tutorial1/portsmouth.sd Data Output:   NA 
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1 The Fledermaus User Interface 
The main Fledermaus application window consists of five important regions: 
 
1. the Main Visualization Window in the center; 
2. the Main Menu Bar that runs along the top of the application;  
3. the Geo-Referencing Info Bar just below the menu bar; 
4. the Control Panel with icons on the upper right hand side of the application; and 
5. the Data Object Control Region along the bottom of the window. 
 
The Main Visualization Window is the viewport into the virtual 3D world. It is primarily a 
display space but does contain a number of controls and interaction functions. The actions of 
the mouse in this space depend on the interaction method and icon mode. Normally the left 
mouse performs rotation or selection, the middle does center on pick, and the right mouse 
button is used for profiling.  
 
The Main Menu Bar across the top contains seven menu options that provide file input and 
output functions, exploration and data set control dialogs, rendering options, options to manage 
data queries and help.  
 
Located just below the main menu is the Geo-Referencing Info Bar, which contains two 
information fields. The left field displays information about the current rendering state 
(Normal, Exploring and Rendering Best).  When the scene is fully rendered in the main window 
the state will be Normal.  As soon as an exploration action occurs, such as manipulating with 
navigation widgets, the system will switch into Exploration mode.  This mode renders the image 
in a somewhat degraded state to make the scene motion smooth.  The moment the exploration 
stops, the system switches into Rendering Best mode while the application works to fully render 
the data in the highest possible resolution. When the rendering is complete the system returns 
to Normal mode.  The second larger field displays the geographic position of the cursor when 
over the Main Visualization Window.  
 
The Icon Control Panel, located to the right of the Main Visualization Window, provides dataset 
configuration and interaction controls. The Control Panel also contains a few of the more 
commonly used system functions. 
  
The Data Object Control Region provides information and controls for the data objects 
actively loaded into Fledermaus. This section provides details that are common to all data object 
types. This resizable region is located along the bottom of the Main Visualization Window. The 
vertical size of this region can be changed by clicking and dragging on the horizontal bar that 
runs along the top of this region. When the cursor is over the resize bar it changes from the 
standard left pointing arrow to a light crosshair cursor. Reducing the size of this region makes 
the Main Visualization Window larger and vice-versa.  
 
The Control Region has two different panels, the Data Set Control and the Geo-Picking panel that 
are activated by click on their respective tabs located on the bottom left edge. Clicking on the 
tab will bring that panel to the front. The relatively simple geo-picking panel and the more 
complex data set control panel are described in a following section. 

 
Note: All user entry fields are displayed in white. All other fields provide display information 
about the current object’s viewing state. 
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1.1 Exercise – Main Menu Bar: Loading a Data Object 
 

1. : Click on File on the Main Menu Bar 
 

2. : Click on Open Data Object 
 
Prepared data is loaded into Fledermaus using the Open Data Object command. The dialog box 
for loading data allows the loading of one or more data objects.  
 
By default, Fledermaus expects to load files that end with the extension “sd”, which stands for 
scientific data.  
 

3. : Navigate to MODULE2/tutorial1/portsmouth.sd to load the Porthsmouth.sd 
(or any other .sd) file by simply double clicking it or select a file ending in “.sd” 
and click the Open button 
 
In windows, the File name entry field in the file selection dialog contains the name of the 
currently selected file. The Cancel button exits the Open Data Object dialog and does not load a 
file. 
 
You will see Porthsmouth.sd appear in the Lower left hand portion of the “Data Object 
Control Region”. 
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2  Main Visualization Window – Navigation 
Fledermaus provides two powerful mechanisms for exploring data objects in the virtual 3D data 
space. These exploration modes enable you to navigate quickly and easily.  
 
§ a mouse-controlled widget navigation interface, based on a centered zoom and rotate data 

manipulation technique; and  
 
§ 3D flight using a six-degree of freedom input device (3D flight will be discussed at length in 

a following tutorial). 
 
Both modes allow you to position a virtual camera in the scene. The resulting view presented to 
you is what the camera sees from its position and orientation within the virtual world. The 
exploration modes use different controls and user input to move this camera about the scene. 
 
Both have their own strengths and weaknesses.  
 
The flight mode provides for smooth navigation across both large and small datasets while the 
widgets provide a fast and effective center, zoom and spin interface, which quickly focuses 
attention on the area of interest.  

T H E  W I D G E T  N A V I G A T I O N  I N T E R F A C E   
 
The mouse based widget navigation (pick and zoom) interface uses on screen widgets and direct 
interaction with the data space. The main point to remember with this interface is that all 
rotations and zoom occur about the center of the screen, and picking on a new location will 
move that point in the scene to the center of the display. The visibility of the widgets can be 

toggled by clicking the widgets button . 

U S I N G  T H E  M O U S E  B U T T O N S  
 
The primary method of moving the data in the Fledermaus visualization window is via the three 
buttons on the mouse. Their use depends on the mode selected on the Control Panel.  The 

three modes are Explore  , Select   and Polygon Select  .  Explore mode is set as the 
default. 

 

        single button mouse operation: left click = click, shift-click = and right click = control-click 

List of Shortcut Keys for Fledermaus 
 
Space bar or G key = Enter Explore Mode. 
S key = Enter Select Mode. 
P key = Polygon Select Mode. 
H key = Toggle Widget Visibility. 
C key = Toggle Color Bar Visibility. 
B key = Toggle Bounding Box Visibility. 
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2.1 Exercise – Explore Mode 
Explore mode optimizes the mouse buttons functionality and aids in quickly and effectively 
navigating around the 3D world. It is unnecessary to pick the surface to see the geographic 
position as the position is continuously updated in the Geo-Referencing Info Bar as the cursor is 
moved over the surface. 
 

Hint:  Clicking on the Reset Camera    button on the Icon Control Panel returns the data 
object to the default camera position. If the data objects are lost from view in the 3D scene simply 
click this button to return to the default viewpoint. 
 

1. :Click, hold and drag (  control click) the left mouse button anywhere on the 
Main Visualization Window to rotate the data about either axis – vertically or 
horizontally.   

 
The object can also be rotated by clicking and dragging directly on the rotation widgets.  
When the surface is being rotated around either axis, the corresponding arrow bar will turn 
blue.  Note that the “N” on the top rotation widget indicates which direction is north. 
 
To set the object to rotate continuously, left click and drag the widget to start the object 
rotating and then click the middle mouse button to lock the rotation on. The arrow bar will 

turn red.  To unlock the rotation left click on the widget again. (  not available) 
 

2. :Click and drag on the cone shaped arrowhead at the top of the vertical axes to 
dynamically change the vertical exaggeration of the object. Note that the value of 
the vertical exaggeration will be shown in the Exag field at the bottom left corner 
of the screen in the Data Object Control Region. 
 

3. : To zoom in and out on an object, click and hold the middle mouse button 
down on a picked position then move the mouse up or to the right to zoom in OR 
down or to the left to zoom out. 
 
The widget on the left side of the Main Visualization Window may also be used to zoom in 
and out.  The right hand side widget is used to pan along the Z-axis. 

P R O F I L I N G  
 
4. :Click and hold the right mouse button and drag the mouse to generate a 

profile. Profiles are displayed in the Profile Dialog. It opens automatically when 
the profile is drawn on the 3D surface.  
 
The colors under the profile represent the color of the surface along the profile.  
 
The axes are labeled with the height and the distance along the profile. 
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The vertical exaggeration, the profile's end points and the length of the profile are 
displayed in the V-Scale, End Points and Distance text fields respectively.  
 
You may click and drag anywhere in the profile to get an exact distance and slope in 
degrees of your selected area. 
 
Clicking on the Profile button will open a window where you may save, open, close or 
make a screen capture of your currently generated profile. 
 

5. :Click on the Profile pull down and select Save Profile button to save the profile 
information to a text file. Each point in the profile will be written to the file as 
distance and height along the profile.  

 

2.2 Exercise – Geo Picking 

Select mode  is used for explicit geo-picking and is often used to support special actions 
for the various loaded data objects. The actual actions depend on the data type loaded and are 
described in detail in another exercise. When a surface is geo-picked, a cross appears at the 
pick point and the coordinates of the point will appear in the Geo-Referencing Info Bar. 
 
1. :Show the Fledermaus geo-picking information. This can be done by selecting 

the geo-picking tab on the bottom of the Fledermaus window 
 
2. :Click on Select Mode on the Control Panel 
 
3. :Click on any surface on the Main Visualization Window with the left mouse 

button to display coordinates, which will appear in the “Current Point” fields. 
 
4. :The middle and right buttons still perform zoom and profile operations 

respectively 
 

Assuming you are still looking at the Portsmouth dataset, you might notice a number of 
linear patterns of small amplitude spikes. To get a better idea of the feature being 
discussed, we will use the locate point button. 

 
5. :Enter: 361450 and 4769896 in the x and y fields respectively. 

 
6. :Hit the locate point button. You should now see the point marker centered on a 

spike. 
 

What do you think these spikes are? * 

2.3 Exercise – Polygon Select Mode 

The Polygon Select  mode is used to draw polygon structures by picking points on the 
visualized data. These polygons are used in conjunction with tools like the Surface Query Tool, 
(explained in a following exercise) and can also be saved into other data objects for 
representing things like track lines, polygonal areas of interest, etc.  In this exercise we will 
delimit an area of bed forms centered on 361219E, 4769722N. 
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1. :Click on Polygon Select Mode on the Control Panel 
 
2. :Click on the surface to define points that characterize the shape of the “rippled” 

area. These points will act as polyline or polygon vertices. 
 
3. : Double click on as last point entered to close 
 
4. :Select Data > Add 3D Line to add a 3D line object into the scene. (this would be 

to mark an area for a specific reason) 
 

5. :On the Data Set Control tab window click on the new Internal 3D lines 
  

6. :Press the Add Polygon Selection button in the 3D Line control panel. Pick new 
points and press the Add Polygon Selection button to add the next line. A 3D Line 
object can contain more than 1 polygon. 
 
*These spikes are real data and are actually strings of lobster traps.  
 
Once the required lines are loaded they can be saved using the File > Save Object menu.  
 
The lines can also be exported as an ASCII XYZ file by pressing the Export XYZ button on 
the 3D Lines control panel and entering the desired file name. This operation is good if you 
want to create 3D polylines instead of polygons. 
 
In Polygon Select mode, the middle and right buttons have the same function as in 
Explore mode – zoom and profile respectively. 

2.4 Exercise – Icon Control Panel – Additional Buttons 
The Control Panel, located to the right of the Main Visualization Window, contains a number of 
other commonly used controls. Reset Camera, Explore, Select and Polygon Select have already 
been discussed above.  

U S I N G  O T H E R  C O N T R O L  P A N E L  B U T T O N S  
 

2.4.1 Exercise – Show Cmap  

1. :The Show Color Map button  is located below the mode select buttons. 
Click this button now. 

 
2. :When the Color Map button is toggled on, the software will show or hide the 

currently loaded color map in the Main Visualization Window. Please note that 
the displayed color map is the system default (Step16) and may not necessarily 
match your currently loaded sd file.   

 
3. :To display the color map associated with your loaded file click on Controls > 

Color Map Display to display the Color Map Control window. 
 
4. :Click on Browse to go to the system’s Color Map Directory.   
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5. :Find the color map that matches your data set and load it.  In this instance, 

click on colorsinterp.cmap to display the current Portsmouth.sd file’s cmap. 
 

6. : You may click anywhere in the Position window to customize placement of 
the color map on the Main Visualization Window.   

2.4.2 Exercise – Bounding Coords 

1. :Click on the Bounding Coords  button  
 

The Bounding Coords button will show or hide the Root Node's bounding box and 
associated coordinate labels. Note that coordinate labels only appear after the object has been 
geo-referenced. 

2.4.3 Exercise – Geo-Reference Units 

1. :Click on the Geo-Reference Units Pull down menu  located beside the 
Geo-reference button.  
 
The geo-referencing units to use in the 3D scene are selected from the Geo-Reference Units pop-
up menu. The default option of Any Units asks the system to automatically figure out which 
units should be used. If the automatic detection fails for some reason, the units can be 
assigned by selecting one of the options including Lat/Long/Height, Easting/Northing 
(UTM), or Meters.  
 

NOTE:  After Geo-Referencing the button’s label will change from ‘no label’ to a unit label 
associated with the loaded data file. Use the geo-reference button a lot. It’s a good habit to 
automatically click it whenever a new dataset is loaded. Features like the profiling won’t work 
properly unless the data is geo-referenced. 

  

2.4.4 Exercise – View Manager 
1. :Click on the Controls menu and select View Manager . 
 

This action opens the View Manager Dialog.  
 

This dialog allows the loading and/or saving of a particular camera position to a file. The 
camera position is not linked to any data objects; it is merely a position and orientation in the 
virtual 3D world.  

 
Selecting a saved view will return the camera position relative to that data object. Saving 
interesting views of data sets allow you to return to these viewpoints quickly and easily at a 
later time. 

 
2. :To save a viewpoint, specify a filename in the View Name text field in the Save 

Current View section of the pop-up window.  
 
3. :Click on the Save button 
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View files will be specified in the Available View window list box. To return to a viewpoint 
that is stored simply click on the file name in the Available Views list box. It will display 
immediately. 
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TUTORIAL II – WORKING WITH SCENES & SCIENTIFIC DATA TYPES 

Scenes & Scientific Data Types 
Introduction 

ne of the primary uses of Fledermaus is its ability to load a variety of data types at different 
resolutions and explore them in a 3D scene. This allows the software to be used for a wide 
range of applications and even multiple times during the same project.  Some typical uses 

of the Fledermaus software include: 

 
§ Geological applications - interactive exploration of seafloor morphology, backscatter, and sub-

surface data to better understand geologic processes. 
 
§ Hydrographic surveys – data ranging from raster chart, historical seabed and ongoing survey data, 

and processing and quality control of large volume high-density multibeam survey data.  
 
§ Geohazard analysis – combination of data from all sources aid in the analysis of hazards and 

planning for offshore engineering development. This includes data from existing maps and seabed 
models combined with sonar Bathymetry and imagery, subsurface profiles, seabed 
characterization, pipeline or cable routes, seabed samples, or proposed structures.  

 
The software has been designed to be object oriented allowing for the addition of many data types. 
The complexity of these objects can vary from simple, such as a label or grid, to highly complex 
types such as the PFM class, which is a full multibeam (XYZ-attribute data) editor/quality control 
object.  
 
Each object type supported by Fledermaus is called a scientific data class or SD class for short. Any 
file that is prepared for loading into Fledermaus is given the filename extension .sd.  
 
Each SD class contains a user interface component, which is displayed in the Data Object Control 
Region of Fledermaus. Interaction with the objects is normally performed through this graphical 
interface; however, controls for general exploration in the Main Visualization Window remain 
basically the same as for any object. 

 

II 

O 
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P U R P O S E  
 

Throughout this tutorial you will: 
 
1. Load a variety of data types (.sd objects) at different resolutions and explore/interact 

with them in a 3D scene 
 
§ Geo-reference and profile multiple data objects to see how things fit together 
§ Work with attribute controls for the surface object 

 
2. Understand what data the SD class represents and understand how data is prepared 

for the visualization process  
 
3. Create and save scenes 

 
4. Explore a pre-created scene that contains a variety of different data types. 
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1 Loading and Geo-Referencing Multiple Objects  

1.1 Exercise – Loading Multiple SD Files 
Fledermaus allows you to load and work with multiple data objects together in a scene.  
 
Data Input:  MODULE2/tutorial2_1/*.sd Data Output:  Saved Scene 
 
1. :Click on File > Open Data Object 
 
Selecting this option displays the standard file selection window.  

Navigate to the module2/tutorial2_1 directory. In this directory you will see five SD files 
labeled can3d30sub, Etopo2, Etopo5, Globe and SRTM30.   

2.  : To add each of these files to the Fledermaus Main Visualization Window, hold 
down the CTRL button and select all the SD files or use SHIFT to select the first 
and last files (and the files in between).  Click the Open button.   

The Open Dialogue window operates/supports the same features as any windows dialogue box 
with regards to file selection (i.e. shift and control keys). While you could load each file 
individually, it is much faster to do a multi-file load.  

 
4. : In the Data Set Control window check or uncheck the checkboxes to turn objects 
on and off. To delete an object from the view, press the Delete key. 
 
5. :Click on Controls > Geo-Referencing.  Select each object in turn by checking the 
object’s check box to show the object’s coordinates. A bounding box will show around 
each of the individual datasets. Click Close to close dialog. 
 
6. :Fledermaus will allow Profiling across multiple objects as if they were a single 
object. Try making profiles that span across the different data sets. 
 
7. :Select an object and change its attributes to wireframe.  
 
Select the data object you wish to modify from the dataset control window. The wire frame 
surface button can be found to the right of the dataset control window. To see the effects of the 
wireframe surface you may have to zoom into your data object.  Wireframe mode is not frequently 
used, but can be useful to visualize how big the surface cell size is.  
 
8. :Use File > Save Scene to save the current scene as multiData.scene. 

 
A scene consists of one or more objects to be loaded along with any transformations and 
visualization parameters that were set when the scene was saved. When you reload the scene 
file you should see it as it was saved. Normally scene file names have the filename extension 
.scene. If you do not specify it then Fledermaus will add it automatically. 

1.2 Exercise – Working With Scenes 
Scenes are used to save and reload complex visualizations constructed over one or more sessions.   
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When opening a scene file the dialog will default to displaying only those files that have the .scene 

extension.   On Macs other file types are grayed out. 
 

 
Data Input: MODULE2/tutorial2_1/multiData.scene  Data Output:  NA 

L O A D  A  S C E N E  
 

1. :Click on File > Open Scene 
 

Selecting this option displays the standard file selection dialog.  

Selecting Open Scene will automatically place *.scene in the Type of File field.   

2. :Open the scene (multiData.scene) you saved in the previous exercise 
 

When a scene is loaded the current data object hierarchy will be replaced with the one 
contained in the loaded scene file. 

E X T R A  C R E D I T :  
1. : Click on Open Data Object and load Area*.sd. 
 
2. : Click on file > Save Scene and save the data as Areas.scene. 
 
3. :Click on File > Open Scene. 
 
4. :Load the file “Areas.scene” from the module2/tutorial2_2 directory  

 
This scene contains several overlapping sections of Portsmouth harbor in New Hampshire. 
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TUTORIAL III – INTERNAL OBJECTS & MISCELLANEOUS DATA TYPES 

Internal and Misc. Data Types 
Introduction 

he previous tutorials have given you a fairly good introduction to much of the functionality 
of Fledermaus, and how Fledermaus handles data. Life would be simple if the job ended 
when the survey was completed, or a better pipe route was engineered. But we often need 
to communicate this information to others. On today’s multi-disciplinary projects, fellow 

team members and or management may not have any understanding of the scientific or engineering 
concepts or be fluent in the jargon that pervades most scientific and engineering fields. Sooner or later 
you will have to communicate what you have been doing and where the money was spent. Fledermaus 
can aid in trying to get the point across and in the process make you look good by adding polish to 
your presentation (see also the following tutorial on movie making). In the case of Fledermaus a 
picture may very well be worth a thousand words. 
 
In this tutorial we will integrate several datasets and use some of the Fledermaus internal objects to 
finish the visualization of an area in San Francisco Bay (data provided by U.S.G.S). 

P U R P O S E  
 

Throughout this tutorial you will: 
 

1. Add contours and save them as 3D line objects. 
 

2. Add planer and point internal objects. 
 

3. Add 3D solid model. 
 

4. Save a scene. 

 

III 

T 
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1    Importing & Using Internal Objects & Misc. Data 
Types 

1.1 Exercise – Contouring a Surface 
Data Input: MODULE2/Tutorial3_1/goldenGateBase.scene       Data Output:  Contours.sd 
 
1.  :Click on File > Open Scene and navigate to and load the Golden Gate scene file. 

You should see part of the floor of the San Francisco Bay colored by depth with the 
headlands and several islands colored in grey. 

 
2.  :Select the Tools menu > Contouring.  Select the GoldenGate.dtm.sd.  The elevation 

Range should be approximately -115.4 to -1.7.  
 
3. :Select the Add Common Charting Intervals button.   This creates a contour interval 

that varies based on the water depth. You can also base your intervals by manually entering a 
Starting Elevation and/or the Elevation Step between contour intervals. 

 
4. :Click the Apply button. This may take a while depending on the speed of your computer. 

 
5.  :Click the Close button when the contour lines appear on the seabed. 
 
6.  :Highlight the Contour_GoldenGate.dtm.sd.  then Click on File > Save Object.  

Navigate to this tutorial directory, MODULE2/Tutorial3, and save the file as 
contours.sd. 

 

1.2 Exercise – Adding and Importing Data 
Data Input: MODULE2/Tutorial3_1/goldenGateBase.scene  Data Output:  N/A 

 
This exercise will just add the final polish and give this presentation a sense of virtual reality.  

1. :Add the water’s surface by clicking Data > Add Plane. A white plane should 
appear. 

 
2. :Put the plane in the correct position by selecting the “internal plane” in the dataset 

control area. You will see a transparency slider, a Height entry field and a Set Color button. 
Next click the Set Color button and choose an appropriate color – i.e. blue/green that 
is similar to the color of sea. Finally, set the transparency to a value where the seabed 
can clearly be seen through the sea surface. 

 
3. :Now for the final touch, we will load the Golden Gate Bridge. This object is a 3DS file that 

can be directly imported. To do this, select File > Import > Import Model tab and 
navigate to this tutorial folder and select Goldgate.3DS, and then select Open.  
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4. :You will see that this object has no real world coordinates associated with it. (Controls > 
GeoReference). We will have to manually move it to where we want it. Select the 
GoldenGate.3DS file. Click the Transform button. A transformation window should 
appear. 

 
5. :Play with the various buttons. The 3 sets of operations, Scale, Translate & Rotate should 

be self-explanatory, though in 3D space, the results of pressing buttons may result in the 
unexpected. The arrow buttons make small increments in the relevant operation. By 
selectively clicking these buttons or manually inputting data you can move, rotate or scale an 
object to pretty much any position. 

 
6. :Once you have used the buttons a bit, you may choose to try to manually move the bridge 

to fit it across San Francisco Bay, or you can type the following numbers: 
 

Remember to hit enter after each text entry! 
Scale Translate Rotate 

0.2 -0.355 0 

0.05 -0.290 0 

2.1 0.4 -90 

Remember to hit enter after each text entry! 

Note: For those users that have the facilities to generate 3d models, it is advised that you do your georeferenceing 
in your generation software, as Fledermaus currently limits the bounds of the object within the original bounding 
coordinates so that rotation of objects can often distort the objects. 

7. :Let’s make the bridge colored similar to real life by changing the color. Select 
GoldenGate.3DS and then click the Set Color button. Choose a satisfactory shade of 
orange that is similar to the color of the real golden gate bridge.  

 
8. :Save the scene in this tutorial directory as GoldenGate.scene. If you do not save the 

scene, you will have to line up the bridge every time you load it. 
 

2 Exercise – Importing Vertical Imagery 
Data Input: MODULE2/Tutorial3_2/site2.scene 220Trans.tif Data Output:  N/A 

 
This exercise demonstrates the use of vertical images and gives supplemental directions on 
how to create masks, which in this case is used to mask out the water column in a sub-bottom 
profile.  

Background information 
 

Before we can bring in a transparent image (either vertical or horizontal), we will have to use 
an image-editing package to insert an alpha channel to be used as the transparency layer. For 
reference, the following is a brief description as to how you would do that. For the sake of 
expediency, we have provided you with a sub-bottom image (courtesy of C&C technologies). 
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Creating a transparency: 
 
This procedure will be described using Adobe Photoshop 6.0, but any graphics package that 
supports transparency layers should be adequate. IVS also provides the ability to create masked 
images by using Image Viewer. If you are curious about seeing this, let your instructor know. 
 
1) Load the image file into Photoshop. 
 
2) Make sure advanced tiff saving options are enabled. 
 
3) Use the rectangular marquee tool to select the entire image. 
 
4) Create a new image and when the new image dialogue comes up, make sure that you select 

transparency under the contents area at the bottom of the window. 
 
5) Past copy of the old image into the new image. 
 
6) Use one of the selection tools to select then delete all non-data areas of the image. 
 
7) Save the image. Select save transparency button at bottom of save dialogue box. 
 

2.1 Importing vertical image into Fledermaus. 
 
We will start with a processed sub-bottom image. To have this image appear correctly in the 
Fledermaus 3D environment, you will need to establish the x and y coordinates of the side 
edges of the image. You will also need to know the z coordinates for the top and bottom of 
the image. With this information, you will be able to load the image into Fledermaus. 
 
1. :Start Fledermaus. 

 
2. :Load site2.scene into Fledermaus. 

 
3. :Under the File > Import menu select Import Vertical Image. This will open a file 

selection dialogue.  
 

4. :Load 220Trans.tif.  
 

5. :Select the vertical image object in the dataset control window. 
 

6. :Enter the min and max x y and z bounds of the image into the end points fields 
to the lower right side of the Fledermaus window (xyz ranges are: 1841829.5, 
1841830.5; 9986072.0, 9966382.0; -3674.5, -2723.0 respectively). 
 

7. :Georeference the data if necessary. 
 

8. :Activate the Mask Out Areas button at the bottom of the Fledermaus window (if 
not selected already). 
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TUTORIAL IV – USING THE IVS BAT 

Using the IVS Bat 
Introduction 

he IVS Bat mode of exploration provides a powerful means to navigate around the 3D data 
space with the use of a 3D (six degree of freedom) input device. A supported 3D input 
device must be connected and turned on before starting this mode. 

 

P U R P O S E  
 

Throughout this tutorial you will: 
 

1. Connect a BAT to a computer 
 
2. Become familiar with the IVS Bat and fly around data 
 
3. Become familiar with movie making by recording a flight path  
 

 

IV 

T 
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1 Bat/Computer Setup 
The 3D input device, or Bat, is shipped from IVS extensively tested and in a state that, other 
than a few connections, the device should operate “right out of the box”. The configuration 
of the Bat parts and connections can be seen below.  
 
Once the Bat is connected to the computer, plugged in and turned on, you will need to set 
up the Fledermaus preferences.  
 

 
 
Front view of Bat:  
 

1. base unit  
2. bat receiver handle 
3. receiver connection ports 
4. transmitter 
5. transmitter connection port  
6. power indicator LED  
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Rear view of Bat:  
 
1. base unit 
2. power port 
3. on/off switch 
4. RS232 connector 
5. dip switches 
6. power transformer 
 

1.1 Exercise – Setting Fledermaus Preferences 
1. :Start Fledermaus 
 
2. :Select File > Preferences. This should bring up the Fledermaus preference window. 
 
3. :In the Preference Group window, select 3D Flying. This will bring up a list of 

3D devices and ports. 
 
4. :Assuming you have purchased, and are using an IVS Bat, you should select 

Polhemus Isotrack II. 
 
5. :Set the port to the device port you are using or in other words the port your 

serial cable is plugged into –- usually port 1. 
 
6. :Click the “Apply Changes” button at the bottom of the window, followed by 

the “Make Default” button.  
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7. :You are finished here in regards to the Bat, so you can exit out by pressing the 
OK button. 

 
8. :To test if your Bat is working properly, select Exploration > 3D Flight. 
 
9. :When you hold down either of the Bat buttons (see below), the predictor 

should appear on the screen and react to your hand movements. 
 
10. :If you are still not sure, import a simple data object, this can done by selecting 

Data > Add Grid. If all is working correctly, you should be able to fly around this 
object.  

 

Recommended bat grips. (Note that either the trigger or top buttons can be used to activate 
bat movement.) 

1.2 Exercise – Trouble Shooting Bat 
If you have problems starting the Bat, you should first check the hardware and software 
configurations:  

• Is the Bat connected to the serial port you are trying to use? 
• Is the Bat turned on?  
• Are the preferences in Fledermaus set to the correct port and type of device? 

If all of the above seem to be in order, then you will have to use the Device3DServer applet 
(which Fledermaus and the Bat use to communicate), which can also be run independently to 
find the fault. 

 
When trouble shooting it is best to directly run the Device3DServer applet from the command 
line so that you see a scrolling list of numbers when the Bat is correctly operating. Once the 
Bat is running you can also then run Fledermaus separately and change to the 3D flight mode.  

O T H E R  T H I N G S  T O  C H E C K :   
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1.3 PC Windows Platform 

If the Bat is turned on and the serial cable is plugged in when Windows is booted, Windows 
will try and configure a serial mouse for the Bat.  This will cause problems. The simple 
solution is don't turn the Bat on until Windows is booted.  

1.4 Exercise – Any Unix platform 
 

1. :Double-check the serial port permissions. Often they are configured by default to 
only allow reading from the serial port. The Bat requires both read and write permissions.  
To check port permissions change directory (cd) into /dev and type “ls –l”. 

Depending on platform the serial port device name is:  

                    SGI                 Sun                  Linux 
 Port #1:  /dev/ttyd1     /dev/term/a      /dev/ttyS0 
 Port #2:  /dev/ttyd2     /dev/term/b      /dev/ttyS1 

2. :If your settings are not correct, you will need to become root or contact 
someone with root permissions:  

Change mode by typing: “chmod 777 port”. This gives full permissions to the port. The 
execute permission (7) is not strictly necessary but is probably a good idea.  

3. :Test the Device by running the program: Device3DServer -h for help  

Example: Device3DServer -device Isotrak2 -port /dev/ttyS0 -v  

Don't forget the -v command for verbose output. You will see a few messages and if all is 
well after 4-8 seconds you should see a continuous stream of numbers. If you do and 
they're not all zeros then the Bat is working and all should be well.  

On the Unix platforms if you get the message unable to open port, and you have 
previously checked the permissions, then this often means that the cable connecting the 
computer to the Bat is missing a NULL modem adapter (or has one too many), or rarely, 
the cable may be failing. 
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2 Becoming familiar with the IVS Bat 

2.1 Exercise – Using the BAT 
 

Data Input:  MODULE2/Tutorial3/Canyon.sd Data Output: N/A 
   
 
1. :Start Fledermaus and load the canyon.sd object from the Tutorial3 directory 

 
2. :To emphasize the topography somewhat enter 6 into the Exag (exaggeration) 

box.  Press Enter 
 

3. :Change the exploration mode to 3D Flight mode by clicking Exploration menu  
> 3D Flight  
 

4. :Try flying inside the canyon from one end to the other. To begin flying, press and 
hold down the trigger button on the 3D input device.  

 
While the button is held down, hand movements of the device are mapped in a natural fashion 
to movements within the 3D scene. 

 
5. :Move forward in the scene by simply pushing your hand forward while holding 

down the trigger 
 

6. :Move to the right by moving your hand to the right. Rotations are accomplished 
in a similar manner 

 
7. :Twist your hand to the left to turn left 

 
8. :Twist your hand upwards to turn up, and so on  

 
The speed of movement in the 3D scene is mapped non-linearly from the hand movements of 
the input device. Slow hand motions provide detailed and fine adjustments while fast 
movements accelerate the exploration speed allowing you to quickly move around the entire 
scene. 
 
To support large data sets, the image of the data is normally degraded when flying. This 
increases the rendering speed of the scene while still supporting large data sets. As soon as you 
let go of the trigger, the flight stops and the scene begins to draw at its best possible resolution. 
At any time you may continue the exploration by pressing the flight trigger button and resuming 
your flight. 

 
9. :Select Controls > Projection 

 
The projection parameters affect the presentation of the virtual 3D world.  

 
In the dialog there are three entry fields that may be used to configure the Near Clipping Planes, 
the Far Clipping Planes and the Global Scene Scale factor. To change any of these settings you would 
type a new value in the appropriate text box and click the Apply or OK button.  Note that the 
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configured default values for the Near and Far Clipping Planes set by the system are not usually 
changed nor do they need to be.  

 
10. :Change the Global Scene Scale value to 20.05. 

 
Changing the global scene scale will change the speed with which you travel through the 3D 
data space. For example, making Global Scene Scale a larger number makes the scene bigger thus it 
will take longer the move across it. 

 
11. :Click the reset camera button 
 
12. :Repeat steps 3 to 5 

 

2.2 Exercise – Recording A Flight Path 
Fledermaus provides the ability to record a flight path used to explore a particular scene. The 
recorded path can then be replayed. Although the flight path can be recorded and played back, to 
create a true high-resolution fly through the movie must be rendered via the separate movieclient 
application provided with the system.  
 
There are four steps to creating a movie in Fledermaus: 
 
1. Generate a flight path in Fledermaus; 
2. Smooth the flight path you have recorded using a smoother; 
3. Use movieclient to generate the your movie. 
 
Step 3 will be covered in another tutorial. 

 
1. :   When you are comfortable with your navigation skills, reset the camera and 

click on the Controls Menu > Movie Controls to create a movie   
 

In general the menu buttons and fields are: 
 
Record  - recording mode can be toggled off or on. Flight paths are recorded at standard NTSC 
rates have a frame rate of thirty frames per second. 

 
Play  - used to preview a movie. It will play back the recorded movie frame by frame. The movie 
length is displayed with the format 'h:mm:ss.ff' where 'h' is the length in hours, 'mm' the length 
in minutes, 'ss' the number of seconds, and 'ff' is the number of frames.  Clicking the mouse 
button in the main display window interrupts the playback. 
 
Pause  - Pause will halt the recorded flight path and display the current camera position. 
 
Rewind   - repositions camera to start of flight path. 
 
Clear  - used to erase the currently active movie. When cleared the length field will be reset to 
'0:0.0' to reflect the fact that the camera positions have been erased from memory. 
 

 
  

2. :Click on the Record toggle button to turn recording on  
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When the Record Button is turned on the camera positions will be saved. As you fly around the 
data, new saved camera positions are always appended to the end of the current movie. Note 
that movies can be recorded using either the 3D flight mode or the widget based interaction 
mode. 

 
Also note you can record some frames, turn off recording then move to another location, turn 
recording back on, and continue adding frames to the movie from this new position.  

 
3. :Click on the Controls Menu > Movie Controls and select Play Current Movie   

 
4. :Click on the File > Save Movie menu option and save the movie as 

marsflight.fph. 
 

Previously saved movies can be loaded via the File > Load Movie menu option 
 
Note: if you don’t have the bat, you can use the widgets to record your flight or you can load 
Canyonflight.fph and play with it to see how each of the control buttons work. 
 

2.3 Exercise – Making Movies 
 

Movie making is the climax of working up your data. By producing a movie, you can distribute 
highlights of your dataset in a versatile mpeg format. Mpegs are playable on practically every 
computer, and are highly compressed so that they can easily be distributed via the Internet. 
With Version 6.0 and later, movie making is a far simpler process, with many of the complex 
technical aspects now made simple through use of the movie client wizard.  

P U R P O S E  
 
Throughout this exercise you will: 

 
1. Prepare data for movie making 
2. Use Movie Client to render a movie 

Data Input:  canyon.sd Data Output:  canyon_s.fph, canyon.scene, canyon.mpg 
 
We will use the flight path and dataset you used in the Fledermaus exercise 2.2.1. with one 
change. That is, to save the sd file into a scene, which is what movieclient expects. Use of the 
scene file is the best way for us to include multiple objects in the animation. 

 
1. : Before we start, make sure your screen saver is off, otherwise you run the risk of 

making a very attractive animation of it. 
 

2. : In Fledermaus open canyon.sd and save it as a .scene file. 
 
3. : Start movieclient. This will open the movieclient wizard, which consists of a flight 

path preview window and an input dialogue. 
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4. : Use the Browse button to select and load both the scene file and the flight path. 
 
5. :Press OK. 
 
6. : You should now see step 2 of the wizard with several fields describing how long you want 

the movie and if you want to smooth the flightpath. Set the length of the movie to 20 
seconds. Save the new smoothed flight path as canyon_s.fph. Press the Smooth 
button. This will smooth the flight you made in Module 1, Tutorial 4. The output file will 
be smoothed by sampling it at an interval specified by the fskip (frame skip) value. The 
simplified path is then sampled by the number of frames you specify by the length of the 
animation. 

 
7. : Then press the OK button. 
 
8. : You should now be on the Render Movie step. This is the area where you enter the type of 

output files you wish to create. We are going to create an MPEG here so leave that pull 
down as is. In the Movie Filename enter canyon.mpeg for the output mpeg. We will 
create a standard MPEG-1 for this exercise. We do encourage you to play with the 
different flavors of MPEG though so that you can judge for yourself which format works 
for you. The IVS MPEG-1 is a good start. It is a balance of image quality vs. files size and 
speed. You can also create your own custom animation output format by pressing the 
Customize button.  

 
9. The Anti-aliasing and Render Magnification fields can be used to improve the quality of the 

output animation at a cost of rendering speed. If you increase the Anti-aliasing you will note 
the value increases to 2 and the preview window doubles in size. The more you increase 
anti-aliasing, the higher number of pixels you will have available to sample into the final 
MPEG resolution. Make sure to set this back to none when you are finished. 

 
The render magnification operation dissects the rendering frame into sections that are 
rendered in sequence and then stitched together. This allow for small screens to render 
large frames (and higher resolution movies). Again this comes at the cost of speed, so 
we will also set this back to none before we proceed.  

 
10. :Click OK.  

 
11. :You will now see a series of frames start to render on your screen. You can’t really do 

anything until the rendering is finished. 
 

 


